Erstellt vor 3 Monaten

Zuletzt geändert vor 2 Wochen

#2925 new wish

Alien 7270v3 -> 3270v3

Erstellt von: xTreame Verantwortlicher:
Priorität: normal Meilenstein: new hardware support
Komponente: avm Version: devel
Stichworte: Beobachter:
Product Id: 7270 Firmware Version:

Beschreibung

Hallo Community,

ich würde gerne auf meiner 3270v3 Fritz OS Version 6.83 laufen lassen, leider ist diese offiziell nicht verfügbar.

Allerdings für die 7270 gibt es eine Fritz OS Version 6.

Wäre echt nett, wenn mit da jemand helfen könnte.

Danke und Gruß

Anhänge (2)

3270_install_type.png (103.1 KB) - hinzugefügt von oliver vor 2 Monaten.
3270_alien.diff (13.6 KB) - hinzugefügt von oliver vor 3 Wochen.

Alle Anhänge herunterladen als: .zip

Änderungshistorie (24)

comment:1 Antwort: Geändert vor 3 Monaten durch oliver

Hi.

Kannst du Logs von der seriellen Konsole bereitstellen, falls beim Flashen was schief läuft. Ich habe keine 3270 und könnte das nicht testen. Ist die Hardware bis auf den Telefonteil denn gleich?

Gruß,
Oliver

comment:2 als Antwort auf: ↑ 1 Geändert vor 3 Monaten durch xTreame

Replying to oliver:

Hi.

Kannst du Logs von der seriellen Konsole bereitstellen, falls beim Flashen was schief läuft. Ich habe keine 3270 und könnte das nicht testen. Ist die Hardware bis auf den Telefonteil denn gleich?

Gruß,
Oliver

Hi Oliver,

danke für deine Antwort.

Die beiden Boxen sind von der Hardware her ähnlich. Wie du schon geschrieben hast fehlt bei meiner Box der Telefonteil. Die 7270 hat 2x Gigabit LAN Ports und 2x Fast Ethernet und meine hat leider nur 4x Fast Ethernet. Desweiteren hat die 7270 drei WLAN Antennen meine Box hat nur zwei.

Aber ich denke, dass es trotzdem funktionieren sollte.

Den Telefonteil kann man ja in der neuen Firmware rauspatchen.

Serielle Konsole sollte kein Problem sein. Da kann ich dir die Logs schicken, falls etwas schief geht.

Wäre cool, wenn du mir auch beschreiben könntest, wie du die Firmware bauen kannst, obwohl sie of­fi­zi­ell in Freetz nicht verfügbar ist.

comment:3 Antwort: Geändert vor 2 Monaten durch oliver

Die Idee ist erstmal eine 3270 Firmware auf Basis der 05.54 zu bauen. Wenn die läuft, dann kann man versuchen auf die 06.xx zu gehen. Ein erster Versuch hängt als Patch an. (Bitte nur die 05.54 als 7270 Basis auswählen!)

comment:4 als Antwort auf: ↑ 3 Geändert vor 2 Monaten durch xTreame

Replying to oliver:

Die Idee ist erstmal eine 3270 Firmware auf Basis der 05.54 zu bauen. Wenn die läuft, dann kann man versuchen auf die 06.xx zu gehen. Ein erster Versuch hängt als Patch an. (Bitte nur die 05.54 als 7270 Basis auswählen!)

Super! Vielen Dank! Ich probiere das und melde mich.

Vielen Dank

Gruß

comment:5 Geändert vor 2 Monaten durch xTreame

Hi Oliver,

meine Box hat die Firmware angenommen ohne Probleme.

Allerdings gibt es leider ein paar Fehler in der Seriellen Konsole und im Webinterface.

Ich hänge die die Meldungen an.

Danke für deine Mühe!

Webinterface:

Lua Run Runtime ERROR in /usr/www/all//home/home.lua:1: ../lua/isp.lua:436: attempt to index field '?' (a nil value)
Lua stack traceback:
	[C]: ?
	../lua/isp.lua:436: in function 'read_list'
	../lua/isp.lua:443: in main chunk
	[C]: ?
	[C]: in function 'require'
	../lua/sip_providerlist.lua:2: in main chunk
	[C]: ?
	[C]: in function 'require'
	../lua/fon_numbers.lua:7: in main chunk
	[C]: ?
	[C]: in function 'require'
	[string "/usr/www/all//home/home.lua:1"]:17: in main chunk

Serielle Konsole

 Jan  1 01:01:07 upnpd[652]: get_file_content: can not open file /etc/default/avm/onlinestoredesc.xml - No such file or directory (2)
Jan  1 01:01:07 upnpd[652]: get_file_content: can not open file /etc/default/avm/usbdesc.xml - No such file or directory (2)

Lua Run Runtime ERROR in /usr/www/all//home/home.lua:1: ../lua/isp.lua:436: attempt to index field '?' (a nil value)
Lua stack traceback:
        [C]: ?
        ../lua/isp.lua:436: in function 'read_list'
        ../lua/isp.lua:443: in main chunk
        [C]: ?
        [C]: in function 'require'
        ../lua/sip_providerlist.lua:2: in main chunk
        [C]: ?
        [C]: in function 'require'
        ../lua/fon_numbers.lua:7: in main chunk
        [C]: ?
        [C]: in function 'require'
        [string "/usr/www/all//home/home.lua:1"]:17: in main chunk

Lua Run Runtime ERROR in /usr/www/all//home/home.lua:2328: [string "/usr/www/all//home/home.lua:2328"]:1: attempt to perform arithmetic on global 'g_MaxBlockInfo' (a nil value)
Lua stack traceback:
        [C]: ?
        [string "/usr/www/all//home/home.lua:2328"]:1: in main chunk

Lua Run Runtime ERROR in /usr/www/all//home/home.lua:2528: [string "/usr/www/all//home/home.lua:2528"]:2: attempt to call global 'create_page_content' (a nil value)
Lua stack traceback:
        [C]: in function 'create_page_content'
        [string "/usr/www/all//home/home.lua:2528"]:2: in main chunk

Lua Run Runtime ERROR in /usr/www/all//home/home.lua:2548: [string "/usr/www/all//home/home.lua:2548"]:1: attempt to index global 'g_coninf_data' (a nil value)
Lua stack traceback:
        [C]: ?
        [string "/usr/www/all//home/home.lua:2548"]:1: in main chunk
Jan  1 01:01:17 upnpd[652]: get_file_content: can not open file /etc/default/avm/onlinestoredesc.xml - No such file or directory (2)
Jan  1 01:01:17 upnpd[652]: get_file_content: can not open file /etc/default/avm/usbdesc.xml - No such file or directory (2)
Jan  1 01:01:23 ctlmgr[648]: BUG slabuser: slab_cache_free(size-32,0x2b300de0): free on already freed object
Jan  1 01:01:23 ctlmgr[648]: [bt] of /usr/bin/avm/ctlmgr[648]:
Jan  1 01:01:23 ctlmgr[648]: [bt]  2acae260 bugmsg+0x30 (/lib/libavmcsock.so.2 at 00045230)
Jan  1 01:01:23 ctlmgr[648]: [bt]  2ac79b04 [2ac79af8] <0+0x2ac79af8>+0xc (/lib/libavmcsock.so.2 at 00010af8)
Jan  1 01:01:23 ctlmgr[648]: [bt]  2ac760f0 [2ac76074] <0+0x2ac76074>+0x7c (/lib/libavmcsock.so.2 at 0000d074)
Jan  1 01:01:23 ctlmgr[648]: [bt]  2ac77190 [2ac770ec] <0+0x2ac770ec>+0xa4 (/lib/libavmcsock.so.2 at 0000e0ec)
Jan  1 01:01:23 ctlmgr[648]: [bt]  2ac78f88 slab_free_wheredebug+0x50 (/lib/libavmcsock.so.2 at 0000ff38)
Jan  1 01:01:23 ctlmgr[648]: [bt]  2ae69c18 station_update_active_stationinfo+0x7b0 (/usr/share/ctlmgr/libwlan.so at 0001f468)
Jan  1 01:01:23 ctlmgr[648]: [bt]  2ae66dac [2ae66cc8] <0+0x2ae66cc8>+0xe4 (/usr/share/ctlmgr/libwlan.so at 0001ccc8)
Jan  1 01:01:23 ctlmgr[648]: [bt]  2ae69e0c station_update_stationinfo+0x100 (/usr/share/ctlmgr/libwlan.so at 0001fd0c)
Jan  1 01:01:23 ctlmgr[648]: [bt]  2ae7294c [2ae728a4] <0+0x2ae728a4>+0xa8 (/usr/share/ctlmgr/libwlan.so at 000288a4)
Jan  1 01:01:23 ctlmgr[648]: [bt]  00431364 [004312d0] <0+0x4312d0>+0x94 (/usr/bin/avm/ctlmgr at 000312d0)
Jan  1 01:01:23 ctlmgr[648]: [bt]  004319a0 FindNodeByCanonicalPath+0x190 (/usr/bin/avm/ctlmgr at 00031810)
Jan  1 01:01:23 ctlmgr[648]: [bt]  00431cf0 [00431a50] <0+0x431a50>+0x2a0 (/usr/bin/avm/ctlmgr at 00031a50)
Jan  1 01:01:23 ctlmgr[648]: [bt]  00432c00 timsgprocessor_do_message+0xfc (/usr/bin/avm/ctlmgr at 00032b04)
Jan  1 01:01:23 ctlmgr[648]: [bt]  0041af88 [0041ae74] <0+0x41ae74>+0x114 (/usr/bin/avm/ctlmgr at 0001ae74)
Jan  1 01:01:23 ctlmgr[648]: [bt]  2ab3a344 msg_iterate_queue+0x5c (/lib/libcm.so.0 at 000042e8)
Jan  1 01:01:23 ctlmgr[648]: [bt]  00412a44 main+0x1ce8 (/usr/bin/avm/ctlmgr at 00010d5c)
Jan  1 01:01:23 ctlmgr[648]: [bt]  2adbfe34 __uClibc_main+0x284 (/lib/libc.so.0 at 00058bb0)
Jan  1 01:01:23 ctlmgr[648]: 1970-01-01 01:01:23 /usr/bin/avm/ctlmgr(648) Assertion `0' failed (slabuser.c:262 userbug)
Jan  1 01:01:23 ctlmgr[648]: Version: 05.54
Jan  1 01:01:23 ctlmgr[648]: Last bugmsg at 1970-01-01 01:01:23:
Jan  1 01:01:23 ctlmgr[648]: > BUG slabuser: slab_cache_free(size-32,0x2b300de0): free on already freed object
Jan  1 01:01:23 ctlmgr[648]: [bt]  2ac79b2c [2ac79af8] <0+0x2ac79af8>+0x34 (/lib/libavmcsock.so.2 at 00010af8)
Jan  1 01:01:23 ctlmgr[648]: [bt]  2ac760f0 [2ac76074] <0+0x2ac76074>+0x7c (/lib/libavmcsock.so.2 at 0000d074)
Jan  1 01:01:23 ctlmgr[648]: [bt]  2ac77190 [2ac770ec] <0+0x2ac770ec>+0xa4 (/lib/libavmcsock.so.2 at 0000e0ec)
Jan  1 01:01:23 ctlmgr[648]: [bt]  2ac78f88 slab_free_wheredebug+0x50 (/lib/libavmcsock.so.2 at 0000ff38)
Jan  1 01:01:23 ctlmgr[648]: [bt]  2ae69c18 station_update_active_stationinfo+0x7b0 (/usr/share/ctlmgr/libwlan.so at 0001f468)
Jan  1 01:01:23 ctlmgr[648]: [bt]  2ae66dac [2ae66cc8] <0+0x2ae66cc8>+0xe4 (/usr/share/ctlmgr/libwlan.so at 0001ccc8)
Jan  1 01:01:23 ctlmgr[648]: [bt]  2ae69e0c station_update_stationinfo+0x100 (/usr/share/ctlmgr/libwlan.so at 0001fd0c)
Jan  1 01:01:23 ctlmgr[648]: [bt]  2ae7294c [2ae728a4] <0+0x2ae728a4>+0xa8 (/usr/share/ctlmgr/libwlan.so at 000288a4)
Jan  1 01:01:23 ctlmgr[648]: [bt]  00431364 [004312d0] <0+0x4312d0>+0x94 (/usr/bin/avm/ctlmgr at 000312d0)
Jan  1 01:01:23 ctlmgr[648]: [bt]  004319a0 FindNodeByCanonicalPath+0x190 (/usr/bin/avm/ctlmgr at 00031810)
Jan  1 01:01:23 ctlmgr[648]: [bt]  00431cf0 [00431a50] <0+0x431a50>+0x2a0 (/usr/bin/avm/ctlmgr at 00031a50)
Jan  1 01:01:23 ctlmgr[648]: [bt]  00432c00 timsgprocessor_do_message+0xfc (/usr/bin/avm/ctlmgr at 00032b04)
Jan  1 01:01:23 ctlmgr[648]: [bt]  0041af88 [0041ae74] <0+0x41ae74>+0x114 (/usr/bin/avm/ctlmgr at 0001ae74)
Jan  1 01:01:23 ctlmgr[648]: [bt]  2ab3a344 msg_iterate_queue+0x5c (/lib/libcm.so.0 at 000042e8)
Jan  1 01:01:23 ctlmgr[648]: [bt]  00412a44 main+0x1ce8 (/usr/bin/avm/ctlmgr at 00010d5c)
Jan  1 01:01:23 ctlmgr[648]: [bt]  2adbfe34 __uClibc_main+0x284 (/lib/libc.so.0 at 00058bb0)
Jan  1 01:01:27 upnpd[652]: get_file_content: can not open file /etc/default/avm/onlinestoredesc.xml - No such file or directory (2)
Jan  1 01:01:27 upnpd[652]: get_file_content: can not open file /etc/default/avm/usbdesc.xml - No such file or directory (2)

Lua Run Runtime ERROR in /usr/www/all//internet/internet_settings.lua:1: ../lua/isp.lua:436: attempt to index field '?' (a nil value)
Lua stack traceback:
        [C]: ?
        ../lua/isp.lua:436: in function 'read_list'
        ../lua/isp.lua:443: in main chunk
        [C]: ?
        [C]: in function 'require'
        [string "/usr/www/all//internet/internet_settings.lu..."]:12: in main chunk

Lua Run Runtime ERROR in /usr/www/all//internet/internet_settings.lua:1441: [string "/usr/www/all//internet/internet_settings.lu..."]:1: attempt to call global 'write_isps_css' (a nil value)
Lua stack traceback:
        [C]: in function 'write_isps_css'
        [string "/usr/www/all//internet/internet_settings.lu..."]:1: in main chunk

Lua Run Runtime ERROR in /usr/www/all//internet/internet_settings.lua:1465: [string "/usr/www/all//internet/internet_settings.lu..."]:1: attempt to call global 'write_authforms_css' (a nil value)
Lua stack traceback:
        [C]: in function 'write_authforms_css'
        [string "/usr/www/all//internet/internet_settings.lu..."]:1: in main chunk

Lua Run Runtime ERROR in /usr/www/all//internet/internet_settings.lua:1466: [string "/usr/www/all//internet/internet_settings.lu..."]:1: attempt to call global 'write_special_css' (a nil value)
Lua stack traceback:
        [C]: in function 'write_special_css'
        [string "/usr/www/all//internet/internet_settings.lu..."]:1: in main chunk

Lua Run Runtime ERROR in /usr/www/all//internet/internet_settings.lua:1534: ../lua/val.lua:52: attempt to index local 'v' (a nil value)
Lua stack traceback:
        [C]: ?
        ../lua/val.lua:52: in function 'write_js_checks_no_active'
        ../lua/val.lua:60: in function 'write_js_checks'
        [string "/usr/www/all//internet/internet_settings.lu..."]:1: in main chunk

Lua Run Runtime ERROR in /usr/www/all//internet/internet_settings.lua:1541: ../lua/val.lua:52: attempt to index local 'v' (a nil value)
Lua stack traceback:
        [C]: ?
        ../lua/val.lua:52: in function 'write_js_checks_no_active'
        [string "/usr/www/all//internet/internet_settings.lu..."]:1: in main chunk

Lua Run Runtime ERROR in /usr/www/all//internet/internet_settings.lua:1547: [string "/usr/www/all//internet/internet_settings.lu..."]:1: attempt to call global 'write_is_oma_ipchange_js' (a nil value)
Lua stack traceback:
        [C]: in function 'write_is_oma_ipchange_js'
        [string "/usr/www/all//internet/internet_settings.lu..."]:1: in main chunk

Lua Run Runtime ERROR in /usr/www/all//internet/internet_settings.lua:1606: [string "/usr/www/all//internet/internet_settings.lu..."]:1: attempt to call global 'initial_provider' (a nil value)
Lua stack traceback:
        [C]: in function 'initial_provider'
        [string "/usr/www/all//internet/internet_settings.lu..."]:1: in main chunk

Lua Run Runtime ERROR in /usr/www/all//internet/internet_settings.lua:1608: [string "/usr/www/all//internet/internet_settings.lu..."]:1: attempt to call global 'write_subprovider_radionames_js' (a nil value)
Lua stack traceback:
        [C]: in function 'write_subprovider_radionames_js'
        [string "/usr/www/all//internet/internet_settings.lu..."]:1: in main chunk

Lua Run Runtime ERROR in /usr/www/all//internet/internet_settings.lua:1610: [string "/usr/www/all//internet/internet_settings.lu..."]:1: attempt to call global 'write_isps_classnames_js' (a nil value)
Lua stack traceback:
        [C]: in function 'write_isps_classnames_js'
        [string "/usr/www/all//internet/internet_settings.lu..."]:1: in main chunk

Lua Run Runtime ERROR in /usr/www/all//internet/internet_settings.lua:1657: [string "/usr/www/all//internet/internet_settings.lu..."]:1: attempt to call global 'write_enablers_js' (a nil value)
Lua stack traceback:
        [C]: in function 'write_enablers_js'
        [string "/usr/www/all//internet/internet_settings.lu..."]:1: in main chunk

Lua Run Runtime ERROR in /usr/www/all//internet/internet_settings.lua:1662: [string "/usr/www/all//internet/internet_settings.lu..."]:1: attempt to call global 'write_focuschanger_js' (a nil value)
Lua stack traceback:
        [C]: in function 'write_focuschanger_js'
        [string "/usr/www/all//internet/internet_settings.lu..."]:1: in main chunk

Lua Run Runtime ERROR in /usr/www/all//internet/internet_settings.lua:1669: [string "/usr/www/all//internet/internet_settings.lu..."]:1: attempt to call global 'write_to_disable_js' (a nil value)
Lua stack traceback:
        [C]: in function 'write_to_disable_js'
        [string "/usr/www/all//internet/internet_settings.lu..."]:1: in main chunk

Lua Run Runtime ERROR in /usr/www/all//internet/internet_settings.lua:1678: [string "/usr/www/all//internet/internet_settings.lu..."]:1: attempt to index global 'wlanscan' (a nil value)
Lua stack traceback:
        [C]: ?
        [string "/usr/www/all//internet/internet_settings.lu..."]:1: in main chunk
Jan  1 01:01:34 ctlmgr[648]: BUG slabuser: slab_cache_free(size-32,0x2b300d20): free on already freed object
Jan  1 01:01:34 ctlmgr[648]: [bt] of /usr/bin/avm/ctlmgr[648]:
Jan  1 01:01:34 ctlmgr[648]: [bt]  2acae260 bugmsg+0x30 (/lib/libavmcsock.so.2 at 00045230)
Jan  1 01:01:34 ctlmgr[648]: [bt]  2ac79b04 [2ac79af8] <0+0x2ac79af8>+0xc (/lib/libavmcsock.so.2 at 00010af8)
Jan  1 01:01:34 ctlmgr[648]: [bt]  2ac760f0 [2ac76074] <0+0x2ac76074>+0x7c (/lib/libavmcsock.so.2 at 0000d074)
Jan  1 01:01:34 ctlmgr[648]: [bt]  2ac77190 [2ac770ec] <0+0x2ac770ec>+0xa4 (/lib/libavmcsock.so.2 at 0000e0ec)
Jan  1 01:01:34 ctlmgr[648]: [bt]  2ac78f88 slab_free_wheredebug+0x50 (/lib/libavmcsock.so.2 at 0000ff38)
Jan  1 01:01:34 ctlmgr[648]: [bt]  2ae69c18 station_update_active_stationinfo+0x7b0 (/usr/share/ctlmgr/libwlan.so at 0001f468)
Jan  1 01:01:34 ctlmgr[648]: [bt]  2ae66dac [2ae66cc8] <0+0x2ae66cc8>+0xe4 (/usr/share/ctlmgr/libwlan.so at 0001ccc8)
Jan  1 01:01:34 ctlmgr[648]: [bt]  2ae69e0c station_update_stationinfo+0x100 (/usr/share/ctlmgr/libwlan.so at 0001fd0c)
Jan  1 01:01:34 ctlmgr[648]: [bt]  2ae7294c [2ae728a4] <0+0x2ae728a4>+0xa8 (/usr/share/ctlmgr/libwlan.so at 000288a4)
Jan  1 01:01:34 ctlmgr[648]: [bt]  00431364 [004312d0] <0+0x4312d0>+0x94 (/usr/bin/avm/ctlmgr at 000312d0)
Jan  1 01:01:34 ctlmgr[648]: [bt]  004319a0 FindNodeByCanonicalPath+0x190 (/usr/bin/avm/ctlmgr at 00031810)
Jan  1 01:01:34 ctlmgr[648]: [bt]  00431cf0 [00431a50] <0+0x431a50>+0x2a0 (/usr/bin/avm/ctlmgr at 00031a50)
Jan  1 01:01:34 ctlmgr[648]: [bt]  00432c00 timsgprocessor_do_message+0xfc (/usr/bin/avm/ctlmgr at 00032b04)
Jan  1 01:01:34 ctlmgr[648]: [bt]  0041af88 [0041ae74] <0+0x41ae74>+0x114 (/usr/bin/avm/ctlmgr at 0001ae74)
Jan  1 01:01:36 ctlmgr[648]: [bt]  2ab3a344 msg_iterate_queue+0x5c (/lib/libcm.so.0 at 000042e8)
Jan  1 01:01:36 ctlmgr[648]: [bt]  00412a44 main+0x1ce8 (/usr/bin/avm/ctlmgr at 00010d5c)
Jan  1 01:01:36 ctlmgr[648]: [bt]  2adbfe34 __uClibc_main+0x284 (/lib/libc.so.0 at 00058bb0)
Jan  1 01:01:36 ctlmgr[648]: 1970-01-01 01:01:36 /usr/bin/avm/ctlmgr(648) Assertion `0' failed (slabuser.c:262 userbug)
Jan  1 01:01:36 ctlmgr[648]: Version: 05.54
Jan  1 01:01:36 ctlmgr[648]: Last bugmsg at 1970-01-01 01:01:34:
Jan  1 01:01:36 ctlmgr[648]: > BUG slabuser: slab_cache_free(size-32,0x2b300d20): free on already freed object
Jan  1 01:01:36 ctlmgr[648]: [bt]  2ac79b2c [2ac79af8] <0+0x2ac79af8>+0x34 (/lib/libavmcsock.so.2 at 00010af8)
Jan  1 01:01:36 ctlmgr[648]: [bt]  2ac760f0 [2ac76074] <0+0x2ac76074>+0x7c (/lib/libavmcsock.so.2 at 0000d074)
Jan  1 01:01:36 ctlmgr[648]: [bt]  2ac77190 [2ac770ec] <0+0x2ac770ec>+0xa4 (/lib/libavmcsock.so.2 at 0000e0ec)
Jan  1 01:01:36 ctlmgr[648]: [bt]  2ac78f88 slab_free_wheredebug+0x50 (/lib/libavmcsock.so.2 at 0000ff38)
Jan  1 01:01:36 ctlmgr[648]: [bt]  2ae69c18 station_update_active_stationinfo+0x7b0 (/usr/share/ctlmgr/libwlan.so at 0001f468)
Jan  1 01:01:36 ctlmgr[648]: [bt]  2ae66dac [2ae66cc8] <0+0x2ae66cc8>+0xe4 (/usr/share/ctlmgr/libwlan.so at 0001ccc8)
Jan  1 01:01:36 ctlmgr[648]: [bt]  2ae69e0c station_update_stationinfo+0x100 (/usr/share/ctlmgr/libwlan.so at 0001fd0c)
Jan  1 01:01:36 ctlmgr[648]: [bt]  2ae7294c [2ae728a4] <0+0x2ae728a4>+0xa8 (/usr/share/ctlmgr/libwlan.so at 000288a4)
Jan  1 01:01:36 ctlmgr[648]: [bt]  00431364 [004312d0] <0+0x4312d0>+0x94 (/usr/bin/avm/ctlmgr at 000312d0)
Jan  1 01:01:36 ctlmgr[648]: [bt]  004319a0 FindNodeByCanonicalPath+0x190 (/usr/bin/avm/ctlmgr at 00031810)
Jan  1 01:01:36 ctlmgr[648]: [bt]  00431cf0 [00431a50] <0+0x431a50>+0x2a0 (/usr/bin/avm/ctlmgr at 00031a50)
Jan  1 01:01:36 ctlmgr[648]: [bt]  00432c00 timsgprocessor_do_message+0xfc (/usr/bin/avm/ctlmgr at 00032b04)
Jan  1 01:01:36 ctlmgr[648]: [bt]  0041af88 [0041ae74] <0+0x41ae74>+0x114 (/usr/bin/avm/ctlmgr at 0001ae74)
Jan  1 01:01:36 ctlmgr[648]: [bt]  2ab3a344 msg_iterate_queue+0x5c (/lib/libcm.so.0 at 000042e8)
Jan  1 01:01:36 ctlmgr[648]: [bt]  00412a44 main+0x1ce8 (/usr/bin/avm/ctlmgr at 00010d5c)
Jan  1 01:01:36 ctlmgr[648]: [bt]  2adbfe34 __uClibc_main+0x284 (/lib/libc.so.0 at 00058bb0)

Lua Run Runtime ERROR in /usr/www/all//internet/internet_settings.lua:1699: [string "/usr/www/all//internet/internet_settings.lu..."]:1: attempt to call global 'write_initial_class' (a nil value)
Lua stack traceback:
        [C]: in function 'write_initial_class'
        [string "/usr/www/all//internet/internet_settings.lu..."]:1: in main chunk

Lua Run Runtime ERROR in /usr/www/all//internet/internet_settings.lua:1701: [string "/usr/www/all//internet/internet_settings.lu..."]:1: attempt to call global 'write_wdsrepeater_div' (a nil value)
Lua stack traceback:
        [C]: in function 'write_wdsrepeater_div'
        [string "/usr/www/all//internet/internet_settings.lu..."]:1: in main chunk

Lua Run Runtime ERROR in /usr/www/all//internet/internet_settings.lua:1702: [string "/usr/www/all//internet/internet_settings.lu..."]:1: attempt to call global 'write_display' (a nil value)
Lua stack traceback:
        [C]: in function 'write_display'
        [string "/usr/www/all//internet/internet_settings.lu..."]:1: in main chunk

Lua Run Runtime ERROR in /usr/www/all//internet/internet_settings.lua:1713: [string "/usr/www/all//internet/internet_settings.lu..."]:5: attempt to call global 'initial_provider' (a nil value)
Lua stack traceback:
        [C]: in function 'initial_provider'
        [string "/usr/www/all//internet/internet_settings.lu..."]:5: in main chunk

Lua Run Runtime ERROR in /usr/www/all//internet/internet_settings.lua:1731: [string "/usr/www/all//internet/internet_settings.lu..."]:1: attempt to call global 'write_provider_explain' (a nil value)
Lua stack traceback:
        [C]: in function 'write_provider_explain'
        [string "/usr/www/all//internet/internet_settings.lu..."]:1: in main chunk

Lua Run Runtime ERROR in /usr/www/all//internet/internet_settings.lua:1734: [string "/usr/www/all//internet/internet_settings.lu..."]:1: attempt to call global 'writehtml_settings' (a nil value)
Lua stack traceback:
        [C]: in function 'writehtml_settings'
        [string "/usr/www/all//internet/internet_settings.lu..."]:1: in main chunk
Jan  1 01:01:37 upnpd[652]: get_file_content: can not open file /etc/default/avm/onlinestoredesc.xml - No such file or directory (2)
Jan  1 01:01:37 upnpd[652]: get_file_content: can not open file /etc/default/avm/usbdesc.xml - No such file or directory (2)
Jan  1 01:01:42 ctlmgr[648]: BUG slabuser: slab_cache_free(size-32,0x2b300de0): free on already freed object
Jan  1 01:01:42 ctlmgr[648]: [bt] of /usr/bin/avm/ctlmgr[648]:
Jan  1 01:01:42 ctlmgr[648]: [bt]  2acae260 bugmsg+0x30 (/lib/libavmcsock.so.2 at 00045230)
Jan  1 01:01:42 ctlmgr[648]: [bt]  2ac79b04 [2ac79af8] <0+0x2ac79af8>+0xc (/lib/libavmcsock.so.2 at 00010af8)
Jan  1 01:01:42 ctlmgr[648]: [bt]  2ac760f0 [2ac76074] <0+0x2ac76074>+0x7c (/lib/libavmcsock.so.2 at 0000d074)
Jan  1 01:01:42 ctlmgr[648]: [bt]  2ac77190 [2ac770ec] <0+0x2ac770ec>+0xa4 (/lib/libavmcsock.so.2 at 0000e0ec)
Jan  1 01:01:42 ctlmgr[648]: [bt]  2ac78f88 slab_free_wheredebug+0x50 (/lib/libavmcsock.so.2 at 0000ff38)
Jan  1 01:01:42 ctlmgr[648]: [bt]  2ae69c18 station_update_active_stationinfo+0x7b0 (/usr/share/ctlmgr/libwlan.so at 0001f468)
Jan  1 01:01:42 ctlmgr[648]: [bt]  2ae66dac [2ae66cc8] <0+0x2ae66cc8>+0xe4 (/usr/share/ctlmgr/libwlan.so at 0001ccc8)
Jan  1 01:01:42 ctlmgr[648]: [bt]  2ae69e0c station_update_stationinfo+0x100 (/usr/share/ctlmgr/libwlan.so at 0001fd0c)
Jan  1 01:01:42 ctlmgr[648]: [bt]  2ae760ac WLAN_GetFirstStationInfo+0x8c (/usr/share/ctlmgr/libwlan.so at 0002c020)
Jan  1 01:01:42 ctlmgr[648]: [bt]  00468a68 [00468608] <0+0x468608>+0x460 (/usr/bin/avm/ctlmgr at 00068608)
Jan  1 01:01:42 ctlmgr[648]: [bt]  00469fc4 _Z25LanDevice_FindNextSiblingPvS_PS_+0x118 (/usr/bin/avm/ctlmgr at 00069eac)
Jan  1 01:01:42 ctlmgr[648]: [bt]  00431470 [004312d0] <0+0x4312d0>+0x1a0 (/usr/bin/avm/ctlmgr at 000312d0)
Jan  1 01:01:42 ctlmgr[648]: [bt]  00432084 [00431a50] <0+0x431a50>+0x634 (/usr/bin/avm/ctlmgr at 00031a50)
Jan  1 01:01:42 ctlmgr[648]: [bt]  00432c00 timsgprocessor_do_message+0xfc (/usr/bin/avm/ctlmgr at 00032b04)
Jan  1 01:01:42 ctlmgr[648]: [bt]  0041af88 [0041ae74] <0+0x41ae74>+0x114 (/usr/bin/avm/ctlmgr at 0001ae74)
Jan  1 01:01:42 ctlmgr[648]: [bt]  2ab3a344 msg_iterate_queue+0x5c (/lib/libcm.so.0 at 000042e8)
Jan  1 01:01:42 ctlmgr[648]: [bt]  00412a44 main+0x1ce8 (/usr/bin/avm/ctlmgr at 00010d5c)
Jan  1 01:01:42 ctlmgr[648]: [bt]  2adbfe34 __uClibc_main+0x284 (/lib/libc.so.0 at 00058bb0)
Jan  1 01:01:42 ctlmgr[648]: 1970-01-01 01:01:42 /usr/bin/avm/ctlmgr(648) Assertion `0' failed (slabuser.c:262 userbug)
Jan  1 01:01:42 ctlmgr[648]: Version: 05.54
Jan  1 01:01:42 ctlmgr[648]: Last bugmsg at 1970-01-01 01:01:42:
Jan  1 01:01:42 ctlmgr[648]: > BUG slabuser: slab_cache_free(size-32,0x2b300de0): free on already freed object
Jan  1 01:01:42 ctlmgr[648]: [bt]  2ac79b2c [2ac79af8] <0+0x2ac79af8>+0x34 (/lib/libavmcsock.so.2 at 00010af8)
Jan  1 01:01:42 ctlmgr[648]: [bt]  2ac760f0 [2ac76074] <0+0x2ac76074>+0x7c (/lib/libavmcsock.so.2 at 0000d074)
Jan  1 01:01:42 ctlmgr[648]: [bt]  2ac77190 [2ac770ec] <0+0x2ac770ec>+0xa4 (/lib/libavmcsock.so.2 at 0000e0ec)
Jan  1 01:01:42 ctlmgr[648]: [bt]  2ac78f88 slab_free_wheredebug+0x50 (/lib/libavmcsock.so.2 at 0000ff38)
Jan  1 01:01:42 ctlmgr[648]: [bt]  2ae69c18 station_update_active_stationinfo+0x7b0 (/usr/share/ctlmgr/libwlan.so at 0001f468)
Jan  1 01:01:42 ctlmgr[648]: [bt]  2ae66dac [2ae66cc8] <0+0x2ae66cc8>+0xe4 (/usr/share/ctlmgr/libwlan.so at 0001ccc8)
Jan  1 01:01:42 ctlmgr[648]: [bt]  2ae69e0c station_update_stationinfo+0x100 (/usr/share/ctlmgr/libwlan.so at 0001fd0c)
Jan  1 01:01:42 ctlmgr[648]: [bt]  2ae760ac WLAN_GetFirstStationInfo+0x8c (/usr/share/ctlmgr/libwlan.so at 0002c020)
Jan  1 01:01:42 ctlmgr[648]: [bt]  00468a68 [00468608] <0+0x468608>+0x460 (/usr/bin/avm/ctlmgr at 00068608)
Jan  1 01:01:42 ctlmgr[648]: [bt]  00469fc4 _Z25LanDevice_FindNextSiblingPvS_PS_+0x118 (/usr/bin/avm/ctlmgr at 00069eac)
Jan  1 01:01:42 ctlmgr[648]: [bt]  00431470 [004312d0] <0+0x4312d0>+0x1a0 (/usr/bin/avm/ctlmgr at 000312d0)
Jan  1 01:01:42 ctlmgr[648]: [bt]  00432084 [00431a50] <0+0x431a50>+0x634 (/usr/bin/avm/ctlmgr at 00031a50)
Jan  1 01:01:42 ctlmgr[648]: [bt]  00432c00 timsgprocessor_do_message+0xfc (/usr/bin/avm/ctlmgr at 00032b04)
Jan  1 01:01:42 ctlmgr[648]: [bt]  0041af88 [0041ae74] <0+0x41ae74>+0x114 (/usr/bin/avm/ctlmgr at 0001ae74)
Jan  1 01:01:42 ctlmgr[648]: [bt]  2ab3a344 msg_iterate_queue+0x5c (/lib/libcm.so.0 at 000042e8)
Jan  1 01:01:42 ctlmgr[648]: [bt]  00412a44 main+0x1ce8 (/usr/bin/avm/ctlmgr at 00010d5c)
Jan  1 01:01:42 ctlmgr[648]: [bt]  2adbfe34 __uClibc_main+0x284 (/lib/libc.so.0 at 00058bb0)
Jan  1 01:01:47 upnpd[652]: get_file_content: can not open file /etc/default/avm/onlinestoredesc.xml - No such file or directory (2)
Jan  1 01:01:47 upnpd[652]: get_file_content: can not open file /etc/default/avm/usbdesc.xml - No such file or directory (2)

comment:6 Geändert vor 2 Monaten durch xTreame

Ich habe beim Firmware bauen folgende Pakete entfernt (abgewählt):

Telephony

Allerdings funktionieren soweit alle Funktionen sprich:

WLAN
Internet via LAN 1

Was mir auch aufgefallen ist, dass die LED's nicht in der richtigen Reihenfolge leuchten.

Das heißt, dass bei aktiviertem WLAN und Internet via LAN 1 nur Power und DSL grün leuchtet. Bzw. bei deaktiviertem DSL trotzdem DSL leuchtet.

Die LAN LED und WLAN LED leuchten nicht.

Zuletzt geändert vor 2 Monaten von xTreame (vorher) (Diff)

comment:7 Geändert vor 2 Monaten durch oliver

Hi xTreame,

entschuldige, dass es so lange gedauert hat… die Tage sind zu kurz… :-)

In der 2. Version habe ich folgendes geändert:

  • remove telephony wird automatisch ausgewählt
  • rc.conf an mehreren Stellen auf 3270 Werte gepatched
  • LED Modul von der 3270 nutzen
  • default-Verzeichnis korrigiert

Im Webinterface würde ich ungerne mit Patches anfangen, da das für mich sehr zeitaufwendig wird.

Gruß,
Oliver

comment:8 Geändert vor 2 Monaten durch xTreame

Hi Oliver,

super vielen Dank! :-)

Ich werde das testen und melde mich wieder.

Gruß,
xTreame

comment:9 Geändert vor 2 Monaten durch xTreame

Hi Oliver,

leider hat das nicht funktioniert.

Die FritzBox lehnt das Update ab.

"Die angegebene Datei enthält keine für Ihr Gerät gültige Firmware."

Bei deinem letzten diff hat das funktioniert.

Vielen Dank.

Gruß,
xTreame

comment:10 Geändert vor 2 Monaten durch oliver

Hi.

Das Patchen hat geklappt? Hast du von vorne mit einem frischen Checkout angefangen? Ich frage, weil er beim diff für eine neue Datei das evtl. an die bestehende anhängt…

comment:11 Geändert vor 2 Monaten durch oliver

Wenn du dir die letzte Zeile von patches/scripts/100-3270_7270.sh anschaust, dann wird da in der var/install unter build/modified der linke Text durch den rechten ersetzt.

Oder hat in der letzten Version das ersetzen des "CONFIG_INSTALL_TYPE" in der rc.conf gefehlt? Wenn in der /etc/init.d/rc.conf auf der Box jetzt noch der alte Wert steht (ur8_16MB…dect_plus_55266), dann wird ein 3270 Image erst wieder nach einem Flashen der recover firmware akzeptiert… (oder mount -o bind mit geänderter rc.conf)

comment:12 Geändert vor 2 Monaten durch xTreame

Hi Oliver,

das patchen hat geklappt. Ich habe mit einem neuen Checkout angefangen.

Ich habe bevor ich die neue Firmware auf der Box eingespielt habe das Recovery Image drauf geladen.

Nur wie oben geschrieben, lehnt die Fritzbox die neue Firmware ab

Zuletzt geändert vor 2 Monaten von xTreame (vorher) (Diff)

Geändert vor 2 Monaten durch oliver

comment:13 Geändert vor 2 Monaten durch xTreame

Hi Oliver,

ich habe einen Fehler gefunden. Ich behebe diesen mal und melde mich wieder.

Das Script: 100-3270_7270.sh

wurde nicht in patches/scripts/ gelegt sondern in den Stamm-Pfad.

comment:14 Geändert vor 2 Monaten durch xTreame

Hi Oliver,

hat funktioniert. Die Box hat die Firmware angenommen.

Allerdings ist im Webinterface nun das Menü komplett "kaputt".

Lua Run Runtime ERROR in /usr/www/all//assis/home.lua:1: module 'capiterm' not found:
	no field package.preload['capiterm']
	no file (errno=2,'No such file or directory') '../lua/capiterm.lua'
	no file (errno=2,'No such file or directory') '../menus/capiterm.lua'
	no file (errno=2,'No such file or directory') '../help/capiterm.lua'
	no file (errno=2,'No such file or directory') './capiterm.lua'
	no file (errno=2,'No such file or directory') '/share/lua/5.1/capiterm.lua'
	no file (errno=2,'No such file or directory') '/share/lua/5.1/capiterm/init.lua'
	no file (errno=2,'No such file or directory') '/lib/capiterm.lua'
	no file (errno=2,'No such file or directory') '/lib/capiterm/init.lua'
	cwd '/usr/www/all/cgi-bin'
	no file (errno=2,'No such file or directory') './capiterm.so'
	no file (errno=2,'No such file or directory') '/lib/capiterm.so'
	no file (errno=2,'No such file or directory') '/lib/loadall.so'
	cwd '/usr/www/all/cgi-bin'
Lua stack traceback:
	[C]: ?
	[C]: ?
	[C]: in function 'require'
	../lua/assi_control.lua:3: in main chunk
	[C]: ?
	[C]: in function 'require'
	[string "/usr/www/all//assis/home.lua:1"]:6: in main chunk


Lua Run Runtime ERROR in /usr/www/all/templates/menu_page_head.html:11: ../menus/menu_show.lua:12: attempt to compare number with boolean
Lua stack traceback:
	[C]: ?
	../menus/menu_show.lua:12: in function 'result'
	../menus/menu.lua:40: in function 'exists_page'
	../menus/menu.lua:173: in function 'add_pages'
	../menus/menu.lua:186: in function 'add_item'
	[string "/usr/www/all/templates/menu_page_head.html:..."]:194: in main chunk

Meinst du nicht, dass wenn wir FritzOS 6 einspielen würden, dass dann einige "lua" Fehler weg wären? Ist das nicht so, dass FritzOS 6 nicht mehr so krass auf lua basiert?

Ich verstehe natürlich total, dass du keine Zeit für große Modifikationen hast. Ich habe davon leider nicht so viel Ahnung. Sonst könnte ich diese Anpassungen auch selbst machen :/

comment:15 Geändert vor 2 Monaten durch oliver

Ich habe mir dein Vorschlag gerade mal angesehen. Dabei sind mir 2 Sachen aufgefallen:

  1. andere Kernelversion → schlecht für das LED-Modul
  2. Ich finde keine Stelle mehr an der für die 7270 das Piglet-Modul geladen wird!?

comment:16 Geändert vor 8 Wochen durch xTreame

Hi Oliver,

kein Problem.

AVM wird natürlich auch einen Grund gehabt haben, kein Update mehr für diese Box zu "bauen".

Vielen Dank aber für deine Mühe!

comment:17 Geändert vor 8 Wochen durch oliver

Ich habe die Konfiguration so erweitert, dass sich auch eine 06 Firmware bauen lässt. Die genannten Punkte aus meinem vorigen Beitrag sind noch nicht gelöst.

comment:18 Geändert vor 8 Wochen durch xTreame

Hi Oliver,

super vielen Dank!

Ich werde mich bei Gelegenheit mal damit auseinander setzen.

comment:19 Geändert vor 8 Wochen durch xTreame

Hi Oliver,

könntest du mir deine .diff Datei anpassen, dass der normale Kernel (alte Kernel der 3270v3) und nur das neue Webinterface 06.x (/usr/www/ und /usr/mww/) benutzt werden.

Ich hatte probiert, eine normale 3270v3 Firmware zu bauen und dann von der 7270 das Webinterface zu benutzen. Aber ich habe irgendwas falsch gemacht, denn das Packen der von mir modifizierten Firmware schlägt fehl.

Wäre super nett!

Danke

Zuletzt geändert vor 8 Wochen von xTreame (vorher) (Diff)

comment:20 Geändert vor 3 Wochen durch oliver

So, habs geschafft mir auf ebay für 1€ eine 3270 zu schießen… :-)

Ich hatte beim C&P der Einstellungen für die rc.conf vergessen die eine Variable in AB_COUNT umzubenennen. Jetzt geht schon mal das Webinterface…

Geändert vor 3 Wochen durch oliver

comment:21 Geändert vor 3 Wochen durch xTreame

Hi Oliver,

super vielen Dank. Ich probiere das gleich aus.

Ich hätte dir auch eine schicken können. Ich habe noch paar rumliegen…

comment:22 Geändert vor 2 Wochen durch er13

  • Komponente von freetz-linux nach avm geändert
  • Meilenstein von freetz-next nach new hardware support geändert
Hinweis: Hilfe zur Verwendung von Tickets finden Sie in TracTickets.