Erstellt vor 4 Jahren

Geschlossen vor 4 Jahren

Zuletzt geändert vor 4 Jahren

#2685 closed defect (worksforme)

openconnect libopenconnect library is v7.04-unknown

Erstellt von: waldoo Verantwortlicher:
Priorität: normal Meilenstein: freetz-next
Komponente: unknown Version: devel
Stichworte: Beobachter:
Product Id: Firmware Version:

Beschreibung

hi zusammen,

beim starten von openconnect mit dem ipv6 patch kommt:

#./openconnect
WARNING: This version of openconnect is v7.04 but
the libopenconnect library is v7.04-unknown
No server specified

wenn mann den ipv6 patch weglässt, dann startet openconnect ohne Fehlermeldung

#./openconnect
No server specified
Usage: openconnect [options] <server>
Open client for Cisco AnyConnect VPN, version v7.04

Getestet auf einer 7270 mit "Statically link libraries"
Das müsste sich noch mal jemand näher ansehen.

Änderungshistorie (3)

comment:2 Geändert vor 4 Jahren durch Whoopie

Wo genau ist das Problem? Funktioniert das Binary nicht? Oder willst Du nur auf dieses WARNING aufmerksam machen?

comment:3 Geändert vor 4 Jahren durch Whoopie

  • Lösung auf worksforme gesetzt
  • Status von new nach closed geändert

comment:4 Geändert vor 4 Jahren durch waldoo

Ich sah bei mir relativ bald nach der Verbindung: DTLS handshake failed: 2
Wenn es bei Dir soweit funktioniert, dann könnte es auch an meinem server liegen. Aktuell bekomme ich gar keinen Traffic mehr über den Tunnel.
Muss ich mir noch mal näher ansehen,da mein Target ja eigentlich eine 7170 ist + iptables und da bleibt ja nur USBroot übrig
Sorry

Hinweis: Hilfe zur Verwendung von Tickets finden Sie in TracTickets.