source: trunk/make/sundtek/Config.in @ 14167

Letzte Änderung dieser Datei seit 14167 war 14167, erstellt von er13 vor 6 Monaten

sundtek:

  • make it depend on FREETZ_KERNEL_VERSION_2_6_19_MIN, according to the sundtek documentation the minimum supported version is 2.6.15 (search for Supported Version 2.6.15+)
Dateigröße: 947 Byte
Zeile 
1config FREETZ_PACKAGE_SUNDTEK
2    bool "Sundtek DVB-C/T/T2 driver"
3    depends on FREETZ_KERNEL_VERSION_2_6_19_MIN
4    select FREETZ_LIB_libdl
5    select FREETZ_LIB_libpthread
6    select FREETZ_LIB_librt if FREETZ_TARGET_ARCH_BE
7    default n
8    help
9        Sundtek closed-source linux driver daemon & client.
10        To use this driver you have to run:
11        export LD_PRELOAD=/usr/lib/libsundtekmediaclient.so
12
13choice
14    depends on FREETZ_PACKAGE_SUNDTEK
15    prompt "Version"
16    default FREETZ_PACKAGE_SUNDTEK_VERSION_2017
17
18    config FREETZ_PACKAGE_SUNDTEK_VERSION_2013
19    bool "130210.134617"
20
21    config FREETZ_PACKAGE_SUNDTEK_VERSION_2017
22    bool "170310.204343"
23endchoice
24
25if FREETZ_PACKAGE_SUNDTEK
26comment "Note: Try using older version if you experience any problems"
27    depends on FREETZ_KERNEL_VERSION_2_6_19_MAX && !FREETZ_PACKAGE_SUNDTEK_VERSION_2013
28
29comment "CAUTION: Use 'replace kernel' to avoid memory leaks!"
30    depends on FREETZ_KERNEL_VERSION_2_6_19 && !FREETZ_REPLACE_KERNEL
31endif
Hinweis: Hilfe zum Repository-Browser finden Sie in TracBrowser.